RRSPORT.CO.UK

    Forum   Gallery   Shop   Sponsors
Home > In Car Electronics > Is the Nav-TV unit faulty? What should I check?
Post Reply  Down to end
Page 1 of 1
 
Animal321



Member Since: 18 Nov 2020
Location: Midlands
Posts: 7

United Kingdom 
Is the Nav-TV unit faulty? What should I check?
















Hi all,

But vague I'm afraid, hope someone can help, I'm no expert on car audio but have been lurking around researching for some time - newly purchased RRSPORT 2006

It's got aftermarket dvd player in the front in along with headrest TVs fitted. Also with digital tv.

All works in the back with the aid of remote controls. However no option for TV or DVD is in the front screen I removed the front screen and saw there is a NavTV unit under as pictured I notice took it out and its model OPV-1lr so research says it should produce an extra menu option
There is also a greeny blue Fakra cable that goes into the back of the monitor that does nothing when I unplug so I guess that's the video feed in.

Perhaps the box is not functional do they just fail? Problem is they are now few and far between.

In the 4x4 screen it displays when I'm in P, N, D, 1, etc and is it nothing supposed to spoof the car unit thinking it's in N or P permanently.. Hence why in thinking box fault or power to box..

Or is there any wire I should check for its power feed or do I need to find another box to test?

I also tried to do the secret menu 753 to test the input but seems like it does not work, so perhaps the box is disabling the function.

Does anyone have any ideas. Your help will be very much appreciated πŸ‘πŸ‘πŸ‘πŸ‘πŸ‘




Last edited by Animal321 on Fri Jan 08 2021 11:17am. Edited 2 times in total

Post #608309 Fri Jan 08 2021 11:10am
View user's profile Send private message View poster's gallery Reply with quote
Andy K



Member Since: 18 Sep 2015
Location: GL
Posts: 3601

England 2005 Range Rover Sport TDV6 HSE Rimini Red

Click image to enlarge


Click image to enlarge



Is it connected into the orange optical cables ?

The blue retangular connector is for Nav.

Is there another round fakra ?

Post #608310 Fri Jan 08 2021 11:14am
View user's profile Send private message View poster's gallery Reply with quote
Animal321



Member Since: 18 Nov 2020
Location: Midlands
Posts: 7

United Kingdom 


Wow thanks for your reply.. πŸ‘πŸ™

Yes there was a connector plugged into the top of the screen top left green hole.

The orange wire connector block is connected to the LED screen, and also one to the nav TV box.

The other connecter is pictured here at very top hard to see


Post #608312 Fri Jan 08 2021 11:23am
View user's profile Send private message View poster's gallery Reply with quote
Andy K



Member Since: 18 Sep 2015
Location: GL
Posts: 3601

England 2005 Range Rover Sport TDV6 HSE Rimini Red

I don’t know much about these being aftermarket

I thought the orange tubing should go into the black box but I dunno

Post #608328 Fri Jan 08 2021 3:27pm
View user's profile Send private message View poster's gallery Reply with quote
Animal321



Member Since: 18 Nov 2020
Location: Midlands
Posts: 7

United Kingdom 

Hi, thanks for your message, yes it seems pretty complex, everything seems to be wired in properly so Im pretty sure the box is screwed.

If anyone has one of these you now don't want can you please PM and I'll buy it off you.

Cheers Thumbs Up

Post #608442 Sun Jan 10 2021 10:58pm
View user's profile Send private message View poster's gallery Reply with quote
Col



Member Since: 02 Sep 2012
Location: Hawkes Bay NZ
Posts: 3404

New Zealand 2013 Range Rover Sport Supercharged Autobiography Santorini Black

It is a long time ago but I fitted one of these to my old pre face-lift 09 plate RRS1, can't really remember but unless you have disconnected it, the black plug shown disconnected in picture as Andy say's I think should go into the black box and the plug in the box goes where the original one removed from. I do remember the installation instruction were a bit vague but not to difficult, I also had two control units, but I think I also had the video in motion as well, as I say it was a few years ago and really can't remember exactly. Saying all that though I was not overly impressed with the whole system taking into account the cost of it, so removed it and fitted a GVIF unit instead, and linked that into a Rosen RSE system, alpine TV Tuner and Alpine 6 disc DVD player which gave me the option of playing a different content on each screen separately to the best of my recollection.

Cheers
Col

Post #608477 Mon Jan 11 2021 9:17pm
View user's profile Send private message View poster's gallery Reply with quote
Animal321



Member Since: 18 Nov 2020
Location: Midlands
Posts: 7

United Kingdom 

Hi Col, thanks for your response, yes those plugs shown disconnected where connected before, I had just unplugged them and had a look at the connectors hoping it was something simple like a bad connection.

Thanks also about the info on it being a bit rubbish, perhaps I'll look into the GVIF

Unfortunatly in car technology is the only thing what really dates the car to be honest. The interior trim and exterior still looks pretty up to date with my eyes.

Anyhow I've fitted a bluetooth wireless unit for now that seems to have kept me occupied for the moment.

Cheers

Post #608570 Wed Jan 13 2021 9:20pm
View user's profile Send private message View poster's gallery Post Reply
Post Reply  Back to top
Page 1 of 1
All times are GMT

Jump to  
Previous Topic | Next Topic >
Posting Rules
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



Site Copyright © 2005-2021 Futuranet Ltd & Martin Lewis
RRSPORT.CO.UK RSS Feed - All Forums

Switch to Mobile site