RRSPORT.CO.UK

    Forum   Gallery   Shop   Sponsors
Home > Faults & Fixes > No power
Post Reply  Down to end
Page 1 of 1
 
1richard1



Member Since: 10 Sep 2019
Location: oldbury
Posts: 75

United Kingdom 2007 Range Rover Sport TDV6 HSE Stornoway Grey
No power

Hi today lost acceleration foot down nothing for about 5 seconds then picks up and ok when it gets going, but slow down or trying to pick speed up hill nothing but slowly loses speed, could it be something simple like a split hose fingers crossed. And there was no messages or warnings on dash?

Any pointers to check myself before getting garages involved atm would be appreciated as things a little tight atm due to covid.

Thanks in advance.

Post #601005 Mon Jun 29 2020 5:36pm
View user's profile Send private message View poster's gallery Reply with quote
1richard1



Member Since: 10 Sep 2019
Location: oldbury
Posts: 75

United Kingdom 2007 Range Rover Sport TDV6 HSE Stornoway Grey

And then today back to normal weird.

Post #601065 Tue Jun 30 2020 4:39pm
View user's profile Send private message View poster's gallery Reply with quote
gogsy1956



Member Since: 15 Jun 2013
Location: Tyne and Wear
Posts: 619

United Kingdom 2010 Range Rover Sport TDV8 HSE Bali Blue

I would have thought split intercooler hoses would be accompanied by lots of black smoke,,, when was your fuel filter last changed 2010 RRS, TDV8
bali Blue / colour coded
side steps / flappy paddles
black perforated leather
22" overfinch
heated everything, TV,fridge ...... now with gold calipers and mud flaps !( black mud flaps that is) !!
Many years ago,,,,, 1955 series 1 landie , sometimes wish I had kept it

Post #601110 Wed Jul 01 2020 6:56pm
View user's profile Send private message View poster's gallery Reply with quote
1richard1



Member Since: 10 Sep 2019
Location: oldbury
Posts: 75

United Kingdom 2007 Range Rover Sport TDV6 HSE Stornoway Grey

Hi no idea when that was done only had the car a year had it serviced when i got her, she is in saturday for mot and disc and pads and mega flush oil and filter ill ask the garage to give her the once over and see if what they recommend. Checked the hose no obvious signs of a split.

Post #601132 Thu Jul 02 2020 6:43am
View user's profile Send private message View poster's gallery Reply with quote
Eaters



Member Since: 11 Apr 2016
Location: East Sussex
Posts: 1267

United Kingdom 2008 Range Rover Sport TDV8 HSE Zermatt Silver

This may help as I had something similar recently

https://www.rrsport.co.uk/forum/topic56289.html Robin
2008 Range Rover Sport TDV8
Awaiting rebuild: NGTF
Gone:
Jaguar S-Type V8 4.2 Sport
MGZTT 190 2.5

Post #601136 Thu Jul 02 2020 8:00am
View user's profile Send private message View poster's gallery Post Reply
Post Reply  Back to top
Page 1 of 1
All times are GMT + 1 Hour

Jump to  
Previous Topic | Next Topic >
Posting Rules
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



Site Copyright © 2005-2020 Futuranet Ltd & Martin Lewis
RRSPORT.CO.UK RSS Feed - All Forums

Switch to Mobile site