RRSPORT.CO.UK

    Forum   Gallery   Shop   Sponsors
Home > My Range Rover Sport > Range rover l320 suspension issue
Post Reply  Down to end
Page 1 of 1
 
LegendZilla



Member Since: 28 Apr 2024
Location: Abha
Posts: 3

Saudi Arabia 2006 Range Rover Sport 4.4 V8 HSE Chawton White
Range rover l320 suspension issue

I have a 2006 range rover sport and I’m pulling my hair right now :/

The issue with Air suspension is so weird

Compressor keeps running, filling and discharging again and again until it burnt.

I bought a new one and installed guess what? Same issue

I found the problem 🥲 whenever the compressor starts to fill the reservoir the right rear strut goes up, the computer sees it’s going up by itself then it opens the exhaust valve and so on…

I replaced both front and middle valve blocks with a new ones, replaced the rear valve block with a good known one, same issue… I have a diagnostic tool and I can see live data, the strut is being filled without a permission from air suspension module.

Please any help would be much appreciated

Post #641574 Sun Apr 28 2024 2:23pm
View user's profile Send private message View poster's gallery Reply with quote
Andy K



Member Since: 18 Sep 2015
Location: GL
Posts: 4806

England 2005 Range Rover Sport TDV6 HSE Rimini Red

Maybe a short in wire to rear block ?

Get it to normal height and unplug rear block.
See what happens.

Post #641576 Sun Apr 28 2024 3:33pm
View user's profile Send private message View poster's gallery Reply with quote
LegendZilla



Member Since: 28 Apr 2024
Location: Abha
Posts: 3

Saudi Arabia 2006 Range Rover Sport 4.4 V8 HSE Chawton White

But if it was a short somewhere it should log a fault code right? Also I didn’t try to unplug the rear valve block, but if so would the compressor still kick in to fill the reservoir? Or the fault will stop it? I will give that a try

Post #641577 Sun Apr 28 2024 4:09pm
View user's profile Send private message View poster's gallery Reply with quote
Andy K



Member Since: 18 Sep 2015
Location: GL
Posts: 4806

England 2005 Range Rover Sport TDV6 HSE Rimini Red

It is possible the whole system will lock out.

You could run the compressor yourself and prove the right doesn’t lift. And TRY and prove it’s electrical

Post #641578 Sun Apr 28 2024 4:57pm
View user's profile Send private message View poster's gallery Reply with quote
LegendZilla



Member Since: 28 Apr 2024
Location: Abha
Posts: 3

Saudi Arabia 2006 Range Rover Sport 4.4 V8 HSE Chawton White

Update:

Found the issue Mr. Green it turned out the used “known as good” rear suspension valve
It was leaking internally causing compressor air to fill the strut without permission from the module

Finally fixed with a new aftermarket valve

Thank you everyone 😁

Post #641859 Sat May 11 2024 7:35am
View user's profile Send private message View poster's gallery Post Reply
Post Reply  Back to top
Page 1 of 1
All times are GMT + 1 Hour

Jump to  
Previous Topic | Next Topic >
Posting Rules
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



Site Copyright © 2005-2024 Futuranet Ltd & Martin Lewis
RRSPORT.CO.UK RSS Feed - All Forums

Switch to Mobile site