RRSPORT.CO.UK

    Forum   Gallery   Shop   Sponsors
Home > Faults & Fixes > Brake servo not working
Post Reply  Down to end
Page 1 of 1
 
Mickey



Member Since: 04 Feb 2021
Location: Yorkshire
Posts: 3

United Kingdom 2006 Range Rover Sport TDV6 HSE Siberian Silver
Brake servo not working

Hi I have a problem with brake servo itermitently ive been told oil gets in vaccum pipe and gets into servo there was a recall to fix this which I have check if my car has had but the question is if it's been done and it's gone again would Land Rover repair the fault again it's cost me a lot already as with not having no brakes my wife went through a brick wall not to mention damage on car as well has anyone come across this too any advise would be much appreciated on this

Post #610761 Sun Feb 28 2021 8:45am
View user's profile Send private message View poster's gallery Reply with quote
Disco_Mikey



Member Since: 08 Apr 2012
Location: Dundee, Scotland
Posts: 3870

United Kingdom 

New vacuum pump, pipework and servo required

Post #610776 Sun Feb 28 2021 12:10pm
View user's profile Send private message View poster's gallery Post Reply
Post Reply  Back to top
Page 1 of 1
All times are GMT + 1 Hour

Jump to  
Previous Topic | Next Topic >
Posting Rules
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



Site Copyright © 2005-2021 Futuranet Ltd & Martin Lewis
RRSPORT.CO.UK RSS Feed - All Forums

Switch to Mobile site