RRSPORT.CO.UK

    Forum   Gallery   Shop   Sponsors
Home > Faults & Fixes > Epb dashboard light???
Post Reply  Down to end
Page 1 of 1
 
Ziceman



Member Since: 08 Nov 2018
Location: Northern Ireland
Posts: 4

United Kingdom 
Epb dashboard light???

Epb dashboard light does not show up at all when turn key or when applying or disengaging, I have tested EPD lever and it does work but it's guess work if it's on or off as no Red P light on dash showing.

Is it a simple fuse?
Is it a MOT fail if no light showing?

Thanks in advance for any advice.

Range rover sport 3.6TD V8 2007.

Post #568554 Thu Nov 08 2018 7:26pm
View user's profile Send private message View poster's gallery Reply with quote
Ziceman



Member Since: 08 Nov 2018
Location: Northern Ireland
Posts: 4

United Kingdom 

Please is there a answer to my questions.

Post #568981 Wed Nov 14 2018 9:02pm
View user's profile Send private message View poster's gallery Reply with quote
Brit Plumber



Member Since: 05 Jan 2018
Location: Sleaford, Lincolnshire
Posts: 559

England 2012 Range Rover Sport Supercharged Autobiography Fuji White

I’ll take a look at the wiring diagram tonight. 2012MY RRS 5.0 Supercharged Autobiography (Current)
67 plate Focus ST Line (Current)
09 Mondeo 2.2 Titanium X Sport (Current)
1942 VEP Ford GPW Jeep (Willys) (Current)

02 Ford Focus TDCI (Brilliant car sadly scrapped)
99 BMW M3GTII (Amazing car, written off By a Fiat)

Post #569007 Thu Nov 15 2018 8:11am
View user's profile Send private message View poster's gallery Reply with quote
Ziceman



Member Since: 08 Nov 2018
Location: Northern Ireland
Posts: 4

United Kingdom 

Thanks @Brit Plumber for reply that would be appreciated,

I tested it today on hill and all is working as it should hearing it coming on and off, but it's only by sound and realising the brake and not moving as I have no light on dashboard confirming it's on or off.

Mark

Post #569024 Thu Nov 15 2018 2:34pm
View user's profile Send private message View poster's gallery Reply with quote
Brit Plumber



Member Since: 05 Jan 2018
Location: Sleaford, Lincolnshire
Posts: 559

England 2012 Range Rover Sport Supercharged Autobiography Fuji White

I’ve looked at the wiring diagram and the control of the lamp is from the Parking Brake Module underneath the car. You could do a continuity check between pin F4 on the module connector to pin 20 on the instrument cluster connector as it may be a wiring issue. If you find a fault in the wiring there is another body to chassis connector which you can check for corrosion. If the wiring has continuity then I think it’s the parking brake module or at least the connector (could be worth giving this connector a real good clean).


 2012MY RRS 5.0 Supercharged Autobiography (Current)
67 plate Focus ST Line (Current)
09 Mondeo 2.2 Titanium X Sport (Current)
1942 VEP Ford GPW Jeep (Willys) (Current)

02 Ford Focus TDCI (Brilliant car sadly scrapped)
99 BMW M3GTII (Amazing car, written off By a Fiat)

Post #569054 Thu Nov 15 2018 10:15pm
View user's profile Send private message View poster's gallery Reply with quote
Ziceman



Member Since: 08 Nov 2018
Location: Northern Ireland
Posts: 4

United Kingdom 

All that went over my head😎, will pass on diagram to someone that understands, hope it's corrosion, I've looked at stripping dashboard and looks like there LEDs soldered and pulling out the clock handles which looks it needs delicate touch which I certainly don't have.

Post #569058 Thu Nov 15 2018 11:04pm
View user's profile Send private message View poster's gallery Post Reply
Post Reply  Back to top
Page 1 of 1
All times are GMT

Jump to  
Previous Topic | Next Topic >
Posting Rules
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



Site Copyright © 2005-2018 Futuranet Ltd & Martin Lewis
RRSPORT.CO.UK RSS Feed - All Forums

Switch to Mobile site