RRSPORT.CO.UK

    Forum   Gallery   Shop   Sponsors
Home > Faults & Fixes > EPB *SORTED* now working, but NO DASH "P" light??
Post Reply  Down to end
Page 1 of 1
 
glennp123



Member Since: 04 Dec 2017
Location: Northern Ireland
Posts: 26

United Kingdom 2007 Range Rover Sport TDV8 HSE Firenze Red
EPB *SORTED* now working, but NO DASH "P" light??

Hi all,

Just recently bought a 07 RRS TDV8. Loving it so far, however i have a few problems with it that i want/need fixed for MOT.

The Electronic Handbrake Switch does nothing! It doesnt put it on or off. A yellow light comes on the dash when started and just stays on till engine is turned off.

Plugged her into snap-on computer and the computer said that the EPB light switch was not active, hence the switch in the centre doing nothing. The computer was able to work the handbrake by putting it on and off as i was listening at the rear wheels and you could hear a noise both times... (does NOT do a loud screeching annoying noise like i have read about)

So bought a new switch and it is just the same, however this time the switch illuminates green like the other buttons in the dark now....

Any ideas as to what i could check or where to go next please... I need this done for MOT.

Now the second problem and this weekend i am going to get her on a lift to check around.

But anyways when i am driving on uneven or rough surfaces there is a knock noise coming from the front drivers side.. it sounds like a drop link or an arm making the noise. Its not really loud but enough to annoy you if the radio isnt on!

Thanks for any input people Smile


Last edited by glennp123 on Tue Dec 19 2017 9:25pm. Edited 3 times in total

Post #542650 Mon Dec 04 2017 8:34pm
View user's profile Send private message View poster's gallery Reply with quote
geoffsnook



Member Since: 19 Nov 2016
Location: cardiff
Posts: 1243

Wales 2005 Range Rover Sport Supercharged HSE Java Black

Front lower arms for the knocking you will need them done for the mot not to sure about but if you cant here the hand brake when you pull the switch then it is not working as you have worked out but if the snap on tool works it then not sure about epb Thumbs Up

Last edited by geoffsnook on Mon Dec 04 2017 9:05pm. Edited 1 time in total

Post #542659 Mon Dec 04 2017 9:01pm
View user's profile Send private message View poster's gallery Reply with quote
glennp123



Member Since: 04 Dec 2017
Location: Northern Ireland
Posts: 26

United Kingdom 2007 Range Rover Sport TDV8 HSE Firenze Red

i have done some more research on the EPB. Apparently there are 2 connectors above the p/s rear wheel which run up to the switch and its common for these to start rubbing cause of the wheel against a bit of plastic covering them! Gonna check it out ASAP.

Yeah, thanks for the reply.. may get her up and see whats what with the arms etc. Thumbs Up

Post #542660 Mon Dec 04 2017 9:03pm
View user's profile Send private message View poster's gallery Reply with quote
geoffsnook



Member Since: 19 Nov 2016
Location: cardiff
Posts: 1243

Wales 2005 Range Rover Sport Supercharged HSE Java Black

There are a few places that rub and a few connectors that get corroded have a look on the sister site disco 3 as they are pretty similar to the sport on many things Thumbs Up

Post #542663 Mon Dec 04 2017 9:07pm
View user's profile Send private message View poster's gallery Reply with quote
glennp123



Member Since: 04 Dec 2017
Location: Northern Ireland
Posts: 26

United Kingdom 2007 Range Rover Sport TDV8 HSE Firenze Red

Heres what im seeing lying underneath just.

Post #542665 Mon Dec 04 2017 9:21pm
View user's profile Send private message View poster's gallery Reply with quote
Cymruambyth



Member Since: 27 Feb 2017
Location: North Wales
Posts: 1203

Wales 2006 Range Rover Sport Supercharged HST Zermatt Silver

glennp123 wrote:
i have done some more research on the EPB. Apparently there are 2 connectors above the p/s rear wheel which run up to the switch and its common for these to start rubbing cause of the wheel against a bit of plastic covering them! Gonna check it out ASAP.

Yeah, thanks for the reply.. may get her up and see whats what with the arms etc. Thumbs Up


I spotted those..almost unprotected wires the other day, ridiculous design! Only had mine less than 3 months and I`m becoming disillusioned with it. Steve.


2006 Zermatt Silver, Range Rover Sport HST 4.2 Supercharged on 22" Stormer Alloys.

Post #542765 Wed Dec 06 2017 12:35pm
View user's profile Send private message View poster's gallery Reply with quote
glennp123



Member Since: 04 Dec 2017
Location: Northern Ireland
Posts: 26

United Kingdom 2007 Range Rover Sport TDV8 HSE Firenze Red

UPDATE!

Handbrake now working! 2 broken wires fouling on chassis. Handbrake now working properly and holds well on a hill in neutral.

One tiny problem though.. the P symbol does not come ON or OFF on the dash? is that an MOT fail?

Im happy that the handbrake is now working however and that it wasnt the dreaded failed unit.

Maybe a wee lesson to all RRS owners out there, just cause the handbrake doesnt work etc automatically means that the unit has packed in. Thumbs Up

Post #543523 Sat Dec 16 2017 7:40pm
View user's profile Send private message View poster's gallery Reply with quote
geoffsnook



Member Since: 19 Nov 2016
Location: cardiff
Posts: 1243

Wales 2005 Range Rover Sport Supercharged HSE Java Black

No it dosent but if it well looked after cleaned and adjusted properly it will never really go wrong either Thumbs Up

Post #543525 Sat Dec 16 2017 7:47pm
View user's profile Send private message View poster's gallery Reply with quote
Disco_Mikey
Site Sponsor


Member Since: 08 Apr 2012
Location: Dundee, Scotland
Posts: 3077

United Kingdom 

4.5 years without an EPB issue Thumbs Up

Though I did have the warning light illuminate once, to tell me there was a fault with the warning light... Rolling Eyes MMP Land Rover - Land Rover + Range Rover Specialist
www.Facebook.com/MMPLandRover

Unit 9, 42 Baird Avenue
Dundee
DD2 3TN

Alive Tuning Authorised Dealer - Performance Tuning + EGR Deletes

Servicing + Repairs / Fault Diagnostics / EU3+EU4 EGR Blanking / Brakes Serviced/Replaced / Timing Belt + Oil Pump Replacement

Software Updates+Upgrades:
4x4 Info Enable / Sat Nav OTM / 3 Flash indicators / RRS Timed Climate Retrofit

Post #543528 Sat Dec 16 2017 9:13pm
View user's profile Send private message View poster's gallery Reply with quote
glennp123



Member Since: 04 Dec 2017
Location: Northern Ireland
Posts: 26

United Kingdom 2007 Range Rover Sport TDV8 HSE Firenze Red

Does anyone know why the dash isnt getting the signal now to put the "P" red symbol light on the dash?
The epb is working now but the dash light doesnt come on or off.

Is there any fuses i could check that links the dash light with the switch/epb module?

Thanks!

Post #543714 Tue Dec 19 2017 2:53pm
View user's profile Send private message View poster's gallery Post Reply
Post Reply  Back to top
Page 1 of 1
All times are GMT + 1 Hour

Jump to  
Previous Topic | Next Topic >
Posting Rules
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



Site Copyright © 2005-2018 Futuranet Ltd & Martin Lewis
RRSPORT.CO.UK RSS Feed - All Forums

Switch to Mobile site