RRSPORT.CO.UK

    Forum   Gallery   Shop   Sponsors
Home > Faults & Fixes > 2006. Radio and sat nav screen stopped working
Post Reply  Down to end
Page 1 of 1
 
Brad83091



Member Since: 23 Jan 2013
Location: Limerick
Posts: 16

Ireland 2006 Range Rover Sport TDV6 HSE Luxury Java Black
2006. Radio and sat nav screen stopped working

In short. The jeep was parked up for the last for 10 days( for no fault of its own). Had to go on a trip yesterday 200km round trip. Went out last night to start up the jeep and noticed both the radio and sat nav screen were both dark... I did a quick search on the forum. I checked the 3 fuses that relate to the radio All were ok.

I hadn't much time to spend investigating. So I set off on my trip with no radio or nav.

I'm just in the door now do I'm seeking sum advice.

Post #546787 Fri Jan 26 2018 12:11am
View user's profile Send private message View poster's gallery Reply with quote
Andy K



Member Since: 18 Sep 2015
Location: GL
Posts: 2027

England 2005 Range Rover Sport TDV6 HSE Rimini Red

well i would start buy checking the headunit has power.

I assume nothing is displayed on the green headunit display? No clock ?

Post #546811 Fri Jan 26 2018 12:22pm
View user's profile Send private message View poster's gallery Reply with quote
Brad83091



Member Since: 23 Jan 2013
Location: Limerick
Posts: 16

Ireland 2006 Range Rover Sport TDV6 HSE Luxury Java Black

No errors on screen. And no clock also

Post #546856 Fri Jan 26 2018 10:03pm
View user's profile Send private message View poster's gallery Reply with quote
Brad83091



Member Since: 23 Jan 2013
Location: Limerick
Posts: 16

Ireland 2006 Range Rover Sport TDV6 HSE Luxury Java Black

Update.

All fuses are ok no problem there. Still both nav and radio are dead.

Where to look next

Post #547627 Sun Feb 04 2018 4:58pm
View user's profile Send private message View poster's gallery Reply with quote
Brad83091



Member Since: 23 Jan 2013
Location: Limerick
Posts: 16

Ireland 2006 Range Rover Sport TDV6 HSE Luxury Java Black

Just did a hard reset and noticed the led lights going into the cd changer flashing?????

Post #547632 Sun Feb 04 2018 5:57pm
View user's profile Send private message View poster's gallery Reply with quote
ondafly



Member Since: 03 Mar 2017
Location: Ireland
Posts: 10

Ireland 2007 Range Rover Sport TDV6 HSE Java Black

how old is the car battery ? it might need changing.

In a bmw m3 I owned, I would regularly have an issue where the Nav/TV would not turn on. I would basically have to "reboot" the system, and did this buy pulling the +/- on the car battery for about 60secs and reconnect. They would come back working after that.

Post #547745 Mon Feb 05 2018 4:37pm
View user's profile Send private message View poster's gallery Reply with quote
Brad83091



Member Since: 23 Jan 2013
Location: Limerick
Posts: 16

Ireland 2006 Range Rover Sport TDV6 HSE Luxury Java Black

2006 vehicle

Battery is 3 years (Bosch).

Did 2 hard resets (different evenings). No improvement

Time to book in with my local independent.


I'll be sickened if it turns out to be some thing simple

Post #547994 Wed Feb 07 2018 10:10pm
View user's profile Send private message View poster's gallery Reply with quote
jason-nike



Member Since: 08 Nov 2013
Location: sussex
Posts: 94

England 

Had a similar issue on my old RRS 2005.
Headunit was dead, no radio, no sat nav, no sound.
Ended up having to replace optical loop, once done all was fine

Post #548000 Wed Feb 07 2018 11:39pm
View user's profile Send private message View poster's gallery Post Reply
Post Reply  Back to top
Page 1 of 1
All times are GMT + 1 Hour

Jump to  
Previous Topic | Next Topic >
Posting Rules
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



Site Copyright © 2005-2018 Futuranet Ltd & Martin Lewis
RRSPORT.CO.UK RSS Feed - All Forums

Switch to Mobile site