RRSPORT.CO.UK

    Forum   Gallery   Shop   Sponsors
Home > General > New injectors all gunked up!
Post Reply  Down to end
Page 1 of 2 12>
 
DJDobsy



Member Since: 25 Nov 2017
Location: Sittingbourne
Posts: 19

United Kingdom 
New injectors all gunked up!

Hi all, had a shaky idle issue which I took to local garage who confirmed 6 injectors failed when he plugged in. Took them off to be tested and had 3 ultrasonic cleaned (guy said they will get my by) the other 3 catastrophic failure so I bought 3 new ones. Installed them all and car ran fine for a week and now suddenly in limp mode with a shaky idle again!
Took out one of the cleaned injectors and it seems to be covered in gunk at the nozzle. Took off a new injector and same thing, gunk. Is this normal to gunk up so soon? Would this likely to be the issue?

55 plate tdv6 2.7
Full service inc fuel filter 6 months ago.

Any help appreciated!

Post #543985 Sun Dec 24 2017 12:18pm
View user's profile Send private message View poster's gallery Reply with quote
Tim in Scotland



Member Since: 30 May 2005
Location: Driving along in my automobile
Posts: 16781

2013 Range Rover Sport SDV6 HSE Stornoway Grey

AFAIK it isn’t something that has been reported here before - I wonder if you need to try a different fuel supplier/ brand and maybe something like Miller’s Injector Cleaning and Cetane enhancing additive added to what remains in your present tank of fuel. 2018 Melting Silver Mini Countryman PHEV - a test car before Seeing if I could go to totally Petrol/Diesel free motoring
2015MY Corris Grey SDv6 HSE Dynamic, the best car I have ever owned, totally reliable only a cou0le of rattles in 3 years, now no longer in my care
Also in my garage is a 1996 TDi300 Defender 90 County HT made into a fake CSW

Post #543987 Sun Dec 24 2017 1:14pm
View user's profile Send private message View poster's gallery Send e-mail Reply with quote
DJDobsy



Member Since: 25 Nov 2017
Location: Sittingbourne
Posts: 19

United Kingdom 

Hi Tim thanks for reply, when I changed the injectors I had under a quarter tank of diesel left in the tank (which had injector cleaner in as I was hoping that would cure the original problem before replacing them). After replacing them I filled up the tank with BP Ultimate and have done so since changing. So I don’t think it’s the fuel.
Maybe another 3 new injectors, just seems strange for the amount of gunk in them considering it’s only been a week (unless that’s normal I don’t know)!

Post #543988 Sun Dec 24 2017 1:22pm
View user's profile Send private message View poster's gallery Reply with quote
jimbg



Member Since: 29 Jan 2013
Location: By the River Dart
Posts: 804

2013 Range Rover Sport SDV6 HSE Orkney Grey

You do not have a fuel bug by any chance? Quite common on boats where the diesel is left for a while.

Has the car car been left for a long period? 2017 Discovery 3.0 HSE Silicon Silver Nimbus interior and a few extra toys

2013 HSE Black, Orkney Grey, Ebony Seats and Ivory Interior SOLD

Post #543990 Sun Dec 24 2017 2:48pm
View user's profile Send private message View poster's gallery Reply with quote
DJDobsy



Member Since: 25 Nov 2017
Location: Sittingbourne
Posts: 19

United Kingdom 

Hi Jim, it’s been used more or less everyday since I bought it just over a year ago, so wouldn’t have thought so. I’m a bit puzzled to be honest.

Post #543991 Sun Dec 24 2017 2:54pm
View user's profile Send private message View poster's gallery Reply with quote
jimbg



Member Since: 29 Jan 2013
Location: By the River Dart
Posts: 804

2013 Range Rover Sport SDV6 HSE Orkney Grey

You may have picked up some dodgy fuel, could be worth treating it anyway.

Google Diesel fuel bug to learn more. 2017 Discovery 3.0 HSE Silicon Silver Nimbus interior and a few extra toys

2013 HSE Black, Orkney Grey, Ebony Seats and Ivory Interior SOLD

Post #543993 Sun Dec 24 2017 3:08pm
View user's profile Send private message View poster's gallery Reply with quote
DJDobsy



Member Since: 25 Nov 2017
Location: Sittingbourne
Posts: 19

United Kingdom 

I’ll chuck some cleaner through see what happens, thanks

Post #543994 Sun Dec 24 2017 3:14pm
View user's profile Send private message View poster's gallery Reply with quote
HughN



Member Since: 10 Sep 2017
Location: West Sussex
Posts: 247

United Kingdom 2006 Range Rover Sport TDV6 HSE Zambezi Silver

jimbg wrote:
You may have picked up some dodgy fuel, could be worth treating it anyway.

Google Diesel fuel bug to learn more.


From my experiences with aircraft (kerosene), there has got to be some water present for the bacteria to really get going: by living on the fuel/water interface they can get everything they need to multiply and form a gloopy 'mat'. That sort of stuff usually bungs up the filter though. "I am never content until I have constructed a model of the subject I am studying. If I succeed in making one, I understand; otherwise I do not" - Lord Kelvin

'06 RRS 2.7 TDV6 HSE
'14 D4 3.0 TDV6 HSE
Disco II Td5 - gone (went to Africa)
Disco I V8 - gone (no engine, brakes or power-steering but towed away by a Suzuki Jimny on a 6ft rope)
Disco I V8 - gone
[Plus two Freelanders I'd rather forget but my wife liked]

Post #543998 Sun Dec 24 2017 3:57pm
View user's profile Send private message View poster's gallery Reply with quote
DJDobsy



Member Since: 25 Nov 2017
Location: Sittingbourne
Posts: 19

United Kingdom 

Ok so I’ve had the RAC out to plug it in and see what’s going on...seems injectors to me but does any one here have any “code reading skills” and can work out what exactly is the problem from photo attached. Thanks I’m advance Steve

Post #544405 Sat Dec 30 2017 7:52pm
View user's profile Send private message View poster's gallery Reply with quote
Disco_Mikey
Site Sponsor


Member Since: 08 Apr 2012
Location: Dundee, Scotland
Posts: 3202

United Kingdom 

THe nozzle of that injector is completely normal. Nothing to worry about Thumbs Up

However, you really need the fault codes cleared, and re-read after a short road test

Is it a shaky idle at all times, or only when cold? MMP Land Rover - Land Rover + Range Rover Specialist
www.Facebook.com/MMPLandRover

Unit 9, 42 Baird Avenue
Dundee
DD2 3TN

Alive Tuning Authorised Dealer - Performance Tuning + EGR Deletes

Servicing + Repairs / Fault Diagnostics / EU3+EU4 EGR Blanking / Brakes Serviced/Replaced / Timing Belt + Oil Pump Replacement

Software Updates+Upgrades:
4x4 Info Enable / Sat Nav OTM / 3 Flash indicators / RRS Timed Climate Retrofit

Post #544407 Sat Dec 30 2017 8:11pm
View user's profile Send private message View poster's gallery Reply with quote
DJDobsy



Member Since: 25 Nov 2017
Location: Sittingbourne
Posts: 19

United Kingdom 

Hi, yeah shakey idle and limp mode is now all the time. The full
Story is I had a shakey idle but fine when driving, took it to my local garage and he said all 6 injectors need replacing. I wondered how if it drove fine and was just a shaky idle so I removed all 6 and gave them to Kent Injection to test and clean if needed. They came back and said yes all 6 have failed the test but 3 catastrophic failure and 3 may be ok for now. So I bought 3 new ones and put on the passenger side bank and put the 3 best old ones in the driver side bank. All was then fine for a week then suddenly it went into limp mode with a shakey idle and a shakey ride. So now I’m wondering if I need to replace the other 3 injectors, called out the RAC to plug in and see if the codes would confirm this. But I’m still not sure 😩. Any help is fully appreciated

Post #544408 Sat Dec 30 2017 8:29pm
View user's profile Send private message View poster's gallery Reply with quote
Disco_Mikey
Site Sponsor


Member Since: 08 Apr 2012
Location: Dundee, Scotland
Posts: 3202

United Kingdom 

If all 6 were shafted, then all 6 should have really been replaced. I guess thats the next logical step... MMP Land Rover - Land Rover + Range Rover Specialist
www.Facebook.com/MMPLandRover

Unit 9, 42 Baird Avenue
Dundee
DD2 3TN

Alive Tuning Authorised Dealer - Performance Tuning + EGR Deletes

Servicing + Repairs / Fault Diagnostics / EU3+EU4 EGR Blanking / Brakes Serviced/Replaced / Timing Belt + Oil Pump Replacement

Software Updates+Upgrades:
4x4 Info Enable / Sat Nav OTM / 3 Flash indicators / RRS Timed Climate Retrofit

Post #544416 Sat Dec 30 2017 11:02pm
View user's profile Send private message View poster's gallery Reply with quote
DJDobsy



Member Since: 25 Nov 2017
Location: Sittingbourne
Posts: 19

United Kingdom 

Thanks for your help mikey 👍 do you work at Bearmach? I’m trying to locate some leak off pipe clips, can’t seem to find them anywhere! Cheers Steve

Post #544433 Sun Dec 31 2017 10:11am
View user's profile Send private message View poster's gallery Reply with quote
Disco_Mikey
Site Sponsor


Member Since: 08 Apr 2012
Location: Dundee, Scotland
Posts: 3202

United Kingdom 

I am only a stockist Thumbs Up

Try Citroen for the clips Wink Thumbs Up MMP Land Rover - Land Rover + Range Rover Specialist
www.Facebook.com/MMPLandRover

Unit 9, 42 Baird Avenue
Dundee
DD2 3TN

Alive Tuning Authorised Dealer - Performance Tuning + EGR Deletes

Servicing + Repairs / Fault Diagnostics / EU3+EU4 EGR Blanking / Brakes Serviced/Replaced / Timing Belt + Oil Pump Replacement

Software Updates+Upgrades:
4x4 Info Enable / Sat Nav OTM / 3 Flash indicators / RRS Timed Climate Retrofit

Post #544437 Sun Dec 31 2017 11:17am
View user's profile Send private message View poster's gallery Reply with quote
DJDobsy



Member Since: 25 Nov 2017
Location: Sittingbourne
Posts: 19

United Kingdom 

Thanks again 👍

Post #544442 Sun Dec 31 2017 12:42pm
View user's profile Send private message View poster's gallery Reply with quote
Post Reply  Back to top
Page 1 of 2 12>
All times are GMT

Jump to  
Previous Topic | Next Topic >
Posting Rules
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



Site Copyright © 2005-2018 Futuranet Ltd & Martin Lewis
RRSPORT.CO.UK RSS Feed - All Forums

Switch to Mobile site