RRSPORT.CO.UK

    Forum   Gallery   Shop   Sponsors
Home > Faults & Fixes > HDC Fault
Post Reply  Down to end
Page 1 of 1
 
Umair12



Member Since: 26 Sep 2017
Location: newcastle
Posts: 1

United Kingdom 2006 Range Rover Sport TDV6 HSE Zermatt Silver
HDC Fault

HI All,

i have just bought a range rover few months back the mistake i did was i got the engine washed and every thing went normal expect the error came up on the speedo meter suspension fault hdc not available special programs are off when i press HDC yellow button it works but when i try to change normal mood into any other mode the error comes up again suspension fault special programs are of.

could any one please suggest what could be to problem and where to look for the fualt? umair

Post #536449 Tue Sep 26 2017 11:07am
View user's profile Send private message View poster's gallery Send e-mail Reply with quote
Kenny_Reed



Member Since: 11 Jan 2018
Location: California
Posts: 3

United States 2006 Range Rover Sport Supercharged Java Black

Tccm got wet behind the battery

Post #545560 Thu Jan 11 2018 9:43pm
View user's profile Send private message View poster's gallery Reply with quote
Tim in Scotland



Member Since: 30 May 2005
Location: Driving along in my automobile
Posts: 16614

2013 Range Rover Sport SDV6 HSE Stornoway Grey

Or the battery itself is low on charge because the alternator is damaged or not putting out enough juice. How old is the battery as it could just be that. 2018 Melting Silver Mini Countryman PHEV - a test car before Seeing if I could go to totally Petrol/Diesel free motoring
2015MY Corris Grey SDv6 HSE Dynamic, the best car I have ever owned, totally reliable only a cou0le of rattles in 3 years, now no longer in my care
Also in my garage is a 1996 TDi300 Defender 90 County HT made into a fake CSW

Post #545562 Thu Jan 11 2018 9:45pm
View user's profile Send private message View poster's gallery Send e-mail Reply with quote
Royrw



Member Since: 12 Nov 2014
Location: Glasgow
Posts: 46

United Kingdom 2009 Range Rover Sport TDV6 HST Santorini Black

i’ve just got the same problem happens saturday morning not sure why but battery and altinator are my hazard lights are flashing various error messages and now won’t start i have a video of the horror but can’t find how to upload the video.
checked the ITC and all looks good and various wiring looms but not sure where to go next
 Range Rover Sport 2009 Stormer edition.

Post #546576 Tue Jan 23 2018 9:50pm
View user's profile Send private message View poster's gallery Post Reply
Post Reply  Back to top
Page 1 of 1
All times are GMT + 1 Hour

Jump to  
Previous Topic | Next Topic >
Posting Rules
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



Site Copyright © 2005-2018 Futuranet Ltd & Martin Lewis
RRSPORT.CO.UK RSS Feed - All Forums

Switch to Mobile site