RRSPORT.CO.UK

    Forum   Gallery   Shop   Sponsors
Home > General > No DAB reception
Post Reply  Down to end
Page 1 of 1
 
J2D



Member Since: 28 Feb 2014
Location: Essex
Posts: 221

United Kingdom 2011 Range Rover Sport 3.0 TDV6 HSE Lux Fuji White
No DAB reception

Our DAB has stopped working recently, all we get is NO RECEPTION, wherever we go.

Has been working fine until a few weeks ago

Any advice on how to fix this? Or is another warranty claim?

Thanks

John

Post #540190 Sun Nov 05 2017 9:07am
View user's profile Send private message View poster's gallery Reply with quote
Simon B



Member Since: 28 Feb 2015
Location: Southampton
Posts: 42

United Kingdom 2010 Range Rover Sport 3.0 TDV6 HSE Java Black

Hi there, Did you get any joy with this as my DAB has now got the same problem so I was wondering what you did to solve it.
Thanks Simon.

Post #543172 Mon Dec 11 2017 3:43pm
View user's profile Send private message View poster's gallery Reply with quote
Tim in Scotland



Member Since: 30 May 2005
Location: Driving along in my automobile
Posts: 15966

2013 Range Rover Sport SDV6 HSE Stornoway Grey

I drove from Scotland to Fareham and back over the last 8 days and as soon as I got south of Carlisle my DAB stopped whereas on previous journies I have always carried DAB right through without even having to retune. Nowhere south of Carlisle could I get a DAB signal although FM was fine (since DAB came out I rarely use FM in the car but that worked fine on the journey) This afternoon I reset the tuner back to DAB and Radio 4 was back to it usual clear self back at home. 2018 Melting Silver Mini Countryman PHEV on order for April delivery, bye bye Land Rover after 21 years and 11 LR products..... all because you won’t give me reassurance that should my SDv6 crankshaft break because of a design fault, not MY fault, but the engine builders fault - it will be replaced for free.
2015MY Corris Grey SDv6 HSE Dynamic, but not for much longer........
Also in my garage is a 1996 TDi300 Defender 90 County HT made into a fake CSW

Post #543182 Mon Dec 11 2017 4:30pm
View user's profile Send private message View poster's gallery Send e-mail Reply with quote
Simon B



Member Since: 28 Feb 2015
Location: Southampton
Posts: 42

United Kingdom 2010 Range Rover Sport 3.0 TDV6 HSE Java Black

I’m in Hampshire so perhaps it’s a problem in the south then.

Post #543185 Mon Dec 11 2017 5:24pm
View user's profile Send private message View poster's gallery Reply with quote
J2D



Member Since: 28 Feb 2014
Location: Essex
Posts: 221

United Kingdom 2011 Range Rover Sport 3.0 TDV6 HSE Lux Fuji White

I have spoke the the dealer about this, he first said to make sure I link the DAB in the settings (as pic below) but it wont let me click on Yes! Anyone got any ideas why?
It is booked in beginning of feb to hopefully get fixed under warranty, but they did say if it needs a software update it won’t be covered 🙄.




John

Post #545556 Thu Jan 11 2018 8:23pm
View user's profile Send private message View poster's gallery Reply with quote
Tim in Scotland



Member Since: 30 May 2005
Location: Driving along in my automobile
Posts: 15966

2013 Range Rover Sport SDV6 HSE Stornoway Grey

I solved my issue by switching to FM for a couple of days and then reselecting DAB and set it to search again and it locked on straight away. Have you checked all your antenna connections on the rearmost windows and thatnone of the antenna wires bonded to the glass isn’t damaged? 2018 Melting Silver Mini Countryman PHEV on order for April delivery, bye bye Land Rover after 21 years and 11 LR products..... all because you won’t give me reassurance that should my SDv6 crankshaft break because of a design fault, not MY fault, but the engine builders fault - it will be replaced for free.
2015MY Corris Grey SDv6 HSE Dynamic, but not for much longer........
Also in my garage is a 1996 TDi300 Defender 90 County HT made into a fake CSW

Post #545557 Thu Jan 11 2018 8:38pm
View user's profile Send private message View poster's gallery Send e-mail Reply with quote
Simon B



Member Since: 28 Feb 2015
Location: Southampton
Posts: 42

United Kingdom 2010 Range Rover Sport 3.0 TDV6 HSE Java Black

Solved my problem, Plug came away from the DAB module, reconnected and hey presto everything is now all ok.

Post #545565 Thu Jan 11 2018 8:46pm
View user's profile Send private message View poster's gallery Reply with quote
J2D



Member Since: 28 Feb 2014
Location: Essex
Posts: 221

United Kingdom 2011 Range Rover Sport 3.0 TDV6 HSE Lux Fuji White

Where is the DAB module?

Post #545670 Fri Jan 12 2018 6:18pm
View user's profile Send private message View poster's gallery Reply with quote
Simon B



Member Since: 28 Feb 2015
Location: Southampton
Posts: 42

United Kingdom 2010 Range Rover Sport 3.0 TDV6 HSE Java Black

No idea, Guy Salmon did it while they had the car for other things, didn’t charge me for that job though which was nice.

Post #545686 Fri Jan 12 2018 9:11pm
View user's profile Send private message View poster's gallery Post Reply
Post Reply  Back to top
Page 1 of 1
All times are GMT

Jump to  
Previous Topic | Next Topic >
Posting Rules
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



Site Copyright © 2005-2018 Futuranet Ltd & Martin Lewis
RRSPORT.CO.UK RSS Feed - All Forums

Switch to Mobile site