RRSPORT.CO.UK

    Forum   Gallery   Shop   Sponsors
Home > Faults & Fixes > Strange noise...
Post Reply  Down to end
Page 1 of 1
 
R1CHD



Member Since: 27 Aug 2017
Location: Warminster
Posts: 32

United Kingdom 2005 Range Rover Sport TDV6 SE Java Black
Strange noise...

Good Moring

I bought a 2005 2.7 diesel yesterday and I have noticed a slight noise it's like a metallic grinding noise like the kind you get when you have a clutch release bearing worn or like when you have a broken bracket and you get that vibration / metallic pinking noise but it's only really noticeable when you are driving along and feather the throttle and with the window down , I can't get it to do it and idle or replicate it stationary, I'm 99% sure it's a broken bracket somewhere that's vibrating but just wondered if anyone had ever experienced this? The car has done 90k, thanks

Post #533887 Sun Aug 27 2017 6:57am
View user's profile Send private message View poster's gallery Reply with quote
R1CHD



Member Since: 27 Aug 2017
Location: Warminster
Posts: 32

United Kingdom 2005 Range Rover Sport TDV6 SE Java Black

Ok so I've been under the car today and found that the heat shield fitted in the middle of the car between the exhaust silencer and propshaft was loose due to the washers pulling through the Tin plate I've removed the plate and found the propshaft center bearing worn/ rubber split, I'll replace both and see if this solves the noise

Post #533960 Mon Aug 28 2017 12:52pm
View user's profile Send private message View poster's gallery Reply with quote
R1CHD



Member Since: 27 Aug 2017
Location: Warminster
Posts: 32

United Kingdom 2005 Range Rover Sport TDV6 SE Java Black

Right I've replaced the center bearing and the noise is still there. Anyone one got any suggestions?? Catalytic converter maybe??

Post #535247 Wed Sep 13 2017 5:57pm
View user's profile Send private message View poster's gallery Reply with quote
Paddi



Member Since: 06 Jul 2012
Location: Hertfordshire
Posts: 1447

United Kingdom 2008 Range Rover Sport TDV8 HSE Java Black

Corroded brake backplates flapping about? Easy enough to check if you can get it up on a lift. 2008 MY Java Black TDV8 HSE

Post #535250 Wed Sep 13 2017 6:18pm
View user's profile Send private message View poster's gallery Reply with quote
R1CHD



Member Since: 27 Aug 2017
Location: Warminster
Posts: 32

United Kingdom 2005 Range Rover Sport TDV6 SE Java Black

Yeah Thays worth a look I'll have to get it on a ramp and see what's going on

Post #535262 Wed Sep 13 2017 7:32pm
View user's profile Send private message View poster's gallery Reply with quote
RRSTDV8



Member Since: 12 Aug 2011
Location: Northamptonshire
Posts: 5419

United Kingdom 2008 Range Rover Sport TDV8 HSE Stornoway Grey

One that happened to me was the EPB cable had come out of the hook that keeps it against the suspension arm. It's in the rear wheel well on both sides. It was rubbing on the wheel and made a similar noise to the one you describe. Easy to push it back in to the hook. 2012 SDV6
2008 TDV8 - it's a labour of love

Post #535281 Wed Sep 13 2017 9:16pm
View user's profile Send private message View poster's gallery Reply with quote
R1CHD



Member Since: 27 Aug 2017
Location: Warminster
Posts: 32

United Kingdom 2005 Range Rover Sport TDV6 SE Java Black

Ah ok thanks I'll check that, I'm hoping it's something simple and not some kind of horror story like a noisy camshaft chain or something

Post #535282 Wed Sep 13 2017 9:21pm
View user's profile Send private message View poster's gallery Reply with quote
R1CHD



Member Since: 27 Aug 2017
Location: Warminster
Posts: 32

United Kingdom 2005 Range Rover Sport TDV6 SE Java Black

Thanks for the suggestions I've checked to find all ok, I am now thinking maybe its a pulley or belt tensioner has any one has issues with pulleys or a belt tensioner?

Post #535355 Thu Sep 14 2017 3:06pm
View user's profile Send private message View poster's gallery Reply with quote
Citizen55



Member Since: 14 Dec 2015
Location: Rollin' in my Five point O (well, 4.2)
Posts: 54

United Kingdom 2006 Range Rover Sport Supercharged Tonga Green

I have the same issue, it's subtle as hell, my my OCD knows the noise is there. I thought it was torque converter although I haven't had it checked out. Any luck solving yours? 2006 Range Rover Sport 4.2 s/c with Arden bodykit

Post #538259 Sat Oct 14 2017 10:49am
View user's profile Send private message View poster's gallery Reply with quote
R1CHD



Member Since: 27 Aug 2017
Location: Warminster
Posts: 32

United Kingdom 2005 Range Rover Sport TDV6 SE Java Black

Hi Citizen55

No unfournetley not I’ve done a lot of research and the noise seems to be mainly on the 2005 vehicles with some reporting no fix but also no failure over thousands of miles, it seems to be a general trait of thevehicle but the genral thought for repair is either the torque converter or transfer box replacement but it seems people have replaced these components and it’s not always cured! My OCD also doesn’t cope well with the annoying noise but it’s a job to know what to do

Post #538261 Sat Oct 14 2017 11:03am
View user's profile Send private message View poster's gallery Post Reply
Post Reply  Back to top
Page 1 of 1
All times are GMT

Jump to  
Previous Topic | Next Topic >
Posting Rules
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



Site Copyright © 2005-2017 Futuranet Ltd & Martin Lewis
RRSPORT.CO.UK RSS Feed - All Forums

Switch to Mobile site