RRSPORT.CO.UK

    Forum   Gallery   Shop   Sponsors
Home > General > Engine top end strip down
Post Reply  Down to end
Page 12 of 13 <123 ... 111213>
 
DerrekL



Member Since: 23 Jul 2015
Location: West Lothian
Posts: 160

United Kingdom 2007 Range Rover Sport TDV6 HSE Stornoway Grey

Andy K wrote:
Wondered how u were going.

Glad it's running.

As for the F check the connectors behind the battery. There are 2 that sort of float.

Black. And grey.

IID will drain all air and lower.

To get air out. Try loosening pipes on the valve block in front of compressor.
Think air will stay in struts though.

The lower button won't work?



Yes indeed, I can only get to it when not at work, then sometimes could see it far enough, oh well glad also got it working Thumbs Up

I do see only one connector that 'floats' behind the battery but didn't see any mate to plug it into, I will check that out again...

The lower button doesn't seem to take it all the way to the bump stops, also I do have the Christmas lights displaying on the dash just now so maybe that's air sus related. RRS 2.7 HSE Stornoway Grey
P38 4.6 HSE V8

Post #538584 Wed Oct 18 2017 10:49am
View user's profile Send private message View poster's gallery Reply with quote
Andy K



Member Since: 18 Sep 2015
Location: GL
Posts: 1454

England 2005 Range Rover Sport TDV6 HSE Rimini Red

there's a black connector low down near battery (at back)

and a grey connector which clips to the plastic side of the battery compartment.

these get disconnected when doing the rear belt

Post #538623 Wed Oct 18 2017 5:25pm
View user's profile Send private message View poster's gallery Reply with quote
DerrekL



Member Since: 23 Jul 2015
Location: West Lothian
Posts: 160

United Kingdom 2007 Range Rover Sport TDV6 HSE Stornoway Grey

I'm still getting the F transmission message on the dash and it is in limp mode Confused

I checked all transmission plugs from behind the battery and still have this small plug left over. I can't see or find a mate for this plug.




 RRS 2.7 HSE Stornoway Grey
P38 4.6 HSE V8

Post #539156 Wed Oct 25 2017 7:57am
View user's profile Send private message View poster's gallery Reply with quote
Andy K



Member Since: 18 Sep 2015
Location: GL
Posts: 1454

England 2005 Range Rover Sport TDV6 HSE Rimini Red

That's for the battery during transit when new.

THe grey connector to the side was one of the ones I talked about.

Is the black one below ok ?

Post #539171 Wed Oct 25 2017 11:13am
View user's profile Send private message View poster's gallery Reply with quote
Andy K



Member Since: 18 Sep 2015
Location: GL
Posts: 1454

England 2005 Range Rover Sport TDV6 HSE Rimini Red

what dash messages are you getting ?

Post #539172 Wed Oct 25 2017 11:14am
View user's profile Send private message View poster's gallery Reply with quote
DerrekL



Member Since: 23 Jul 2015
Location: West Lothian
Posts: 160

United Kingdom 2007 Range Rover Sport TDV6 HSE Stornoway Grey

OK good... plug not required, that's good news.

All other plugs in that area behind the battery have a place to go, no issues there.

The message displays something like 'limited gears only...' I will need to check exactly what the message displays. But when I last drove it is not getting any gears, seems to be in limp mode only. BTW it seems to rev up OK when in park.

Next picture quiz: Thumbs Up
Got this plug also spare!!!! which is on the LH side bank, again there is no other mate for it nearby. Every other plug in that area has a mate. Recognise it?




 RRS 2.7 HSE Stornoway Grey
P38 4.6 HSE V8

Post #539176 Wed Oct 25 2017 12:25pm
View user's profile Send private message View poster's gallery Reply with quote
Disco_Mikey
Site Sponsor


Member Since: 08 Apr 2012
Location: Dundee, Scotland
Posts: 2869

United Kingdom 

Fuel Rail Pressure Sensor MMP Land Rover - Land Rover + Range Rover Specialist
www.Facebook.com/MMPLandRover

Unit 9, 42 Baird Avenue
Dundee
DD2 3TN

Alive Tuning Authorised Dealer - Performance Tuning + EGR Deletes

Servicing + Repairs / Fault Diagnostics / EU3+EU4 EGR Blanking / Brakes Serviced/Replaced / Timing Belt + Oil Pump Replacement

Software Updates+Upgrades:
4x4 Info Enable / Sat Nav OTM / 3 Flash indicators / RRS Timed Climate Retrofit

Post #539186 Wed Oct 25 2017 2:20pm
View user's profile Send private message View poster's gallery Reply with quote
DerrekL



Member Since: 23 Jul 2015
Location: West Lothian
Posts: 160

United Kingdom 2007 Range Rover Sport TDV6 HSE Stornoway Grey

OK cheers Mikey, and where might that plug into? as there is no other plug around that area. RRS 2.7 HSE Stornoway Grey
P38 4.6 HSE V8

Post #539188 Wed Oct 25 2017 2:44pm
View user's profile Send private message View poster's gallery Reply with quote
Andy K



Member Since: 18 Sep 2015
Location: GL
Posts: 1454

England 2005 Range Rover Sport TDV6 HSE Rimini Red

I think that's the cam sensor on passenger head, and would explain it


I think you should have moved over the old old cam sensor to the replacement passenger head.
Finding where in goes is a little tricky. You sort of have to do it from the top of the engine, buts its on the side.
have a look at the old head

Also check :

knock sensors plugged in (grey connectors on top of engine)
EGR's plugged in (all 3)

Post #539201 Wed Oct 25 2017 5:17pm
View user's profile Send private message View poster's gallery Reply with quote
Disco_Mikey
Site Sponsor


Member Since: 08 Apr 2012
Location: Dundee, Scotland
Posts: 2869

United Kingdom 

DerrekL wrote:
OK cheers Mikey, and where might that plug into? as there is no other plug around that area.


The pressure sensor on the end of the fuel rail Whistle

It's not the Cam sensor. The car wouldn't start off thatbwas unplugged. And it's grey. As is the EGR connector which has 5 wires

The only thing it can be is the rail pressure sensor MMP Land Rover - Land Rover + Range Rover Specialist
www.Facebook.com/MMPLandRover

Unit 9, 42 Baird Avenue
Dundee
DD2 3TN

Alive Tuning Authorised Dealer - Performance Tuning + EGR Deletes

Servicing + Repairs / Fault Diagnostics / EU3+EU4 EGR Blanking / Brakes Serviced/Replaced / Timing Belt + Oil Pump Replacement

Software Updates+Upgrades:
4x4 Info Enable / Sat Nav OTM / 3 Flash indicators / RRS Timed Climate Retrofit

Post #539213 Wed Oct 25 2017 6:58pm
View user's profile Send private message View poster's gallery Reply with quote
Andy K



Member Since: 18 Sep 2015
Location: GL
Posts: 1454

England 2005 Range Rover Sport TDV6 HSE Rimini Red

That looks like the front of the engine to me with the cam belt cover.

On my engine there are no fuel pressure sensors at the front of the engine.
Only a 2 pin temp sensor in the middle of the V

Some engines will start without cam sensor in limp mode.
Can't remember what the cam sensor plug looks like but I do admit it's small


Yes I know thats not the EGR plugs but they are worth a check


Embarassed Bow down

Post #539215 Wed Oct 25 2017 7:21pm
View user's profile Send private message View poster's gallery Reply with quote
Disco_Mikey
Site Sponsor


Member Since: 08 Apr 2012
Location: Dundee, Scotland
Posts: 2869

United Kingdom 

Rail sensor is in a different location between your EU3 model and his EU4 Thumbs Up

The TDV6 certainly won't start without a correct cam sensor signal MMP Land Rover - Land Rover + Range Rover Specialist
www.Facebook.com/MMPLandRover

Unit 9, 42 Baird Avenue
Dundee
DD2 3TN

Alive Tuning Authorised Dealer - Performance Tuning + EGR Deletes

Servicing + Repairs / Fault Diagnostics / EU3+EU4 EGR Blanking / Brakes Serviced/Replaced / Timing Belt + Oil Pump Replacement

Software Updates+Upgrades:
4x4 Info Enable / Sat Nav OTM / 3 Flash indicators / RRS Timed Climate Retrofit

Post #539227 Thu Oct 26 2017 12:11am
View user's profile Send private message View poster's gallery Reply with quote
DerrekL



Member Since: 23 Jul 2015
Location: West Lothian
Posts: 160

United Kingdom 2007 Range Rover Sport TDV6 HSE Stornoway Grey

Disco_Mikey wrote:
DerrekL wrote:
OK cheers Mikey, and where might that plug into? as there is no other plug around that area.


The pressure sensor on the end of the fuel rail Whistle

It's not the Cam sensor. The car wouldn't start off thatbwas unplugged. And it's grey. As is the EGR connector which has 5 wires

The only thing it can be is the rail pressure sensor



Yes indeed Embarassed I was actually pushing the plug out the way but against the thing it should have been plugged into... the end of the fuel rail. How did I not see that DOH!

All plugs seem to now have a home and when I started the car no 'F' gearbox message on dash for a wee while i.e. drove it a few hundred meters but it still insists in staying in limp mode and F appears intermittently. Brake switch seems OK, battery seems OK. Anything else worth checking or replacing? It's surely something electrical/software related, worth getting the codes read and deleted? RRS 2.7 HSE Stornoway Grey
P38 4.6 HSE V8

Post #539231 Thu Oct 26 2017 7:28am
View user's profile Send private message View poster's gallery Reply with quote
DerrekL



Member Since: 23 Jul 2015
Location: West Lothian
Posts: 160

United Kingdom 2007 Range Rover Sport TDV6 HSE Stornoway Grey

Andy K wrote:
That looks like the front of the engine to me with the cam belt cover.

On my engine there are no fuel pressure sensors at the front of the engine.
Only a 2 pin temp sensor in the middle of the V

Some engines will start without cam sensor in limp mode.
Can't remember what the cam sensor plug looks like but I do admit it's small


Yes I know thats not the EGR plugs but they are worth a check


Embarassed Bow down


Thanks Andy, all plugs should now be in their respective places, hopefully Thumbs Up I just need to sus out what is going on with this limp mode carry on. I have checked the brake switch, battery as I have read in previous posts this can be a source of this kind of trouble.

The christmas tree dash lights come on after a couple of minutes but if I turn car off/on the lights go out but it still is in limp mode. RRS 2.7 HSE Stornoway Grey
P38 4.6 HSE V8

Post #539233 Thu Oct 26 2017 7:35am
View user's profile Send private message View poster's gallery Reply with quote
Andy K



Member Since: 18 Sep 2015
Location: GL
Posts: 1454

England 2005 Range Rover Sport TDV6 HSE Rimini Red

I guess you need to think back to what you have touched.

and what sensors (if any) you have reused off the replacement heads
(excluding green oil pressure.)

Post #539264 Thu Oct 26 2017 11:49am
View user's profile Send private message View poster's gallery Reply with quote
Post Reply  Back to top
Page 12 of 13 <123 ... 111213>
All times are GMT

Jump to  
Previous Topic | Next Topic >
Posting Rules
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



Site Copyright © 2005-2017 Futuranet Ltd & Martin Lewis
RRSPORT.CO.UK RSS Feed - All Forums

Switch to Mobile site