RRSPORT.CO.UK

    Forum   Gallery   Shop   Sponsors
Home > Europe > Suspension & Sat Nav Issue - Help!
Post Reply  Down to end
Page 1 of 1
 
m3grant



Member Since: 05 Dec 2011
Location: Carlisle
Posts: 18

United Kingdom 2006 Range Rover Sport TDV6 HSE Java Black
Suspension & Sat Nav Issue - Help!

Hi, I have a couple of strange issues with my 2006 plate 2.7 v6 Diesel HSE sport in the United Kingdom.

The first is the Sat Nav screen. It started a few months ago when I got in the car early in the morning and the touch screen wouldn't work (it was stuck on the safety warning screen thing). After 10 mins of driving it started to work absolutely fine. This is now the case every single morning......unless I rub my finger all over the screen for 10 seconds or so at which point it will work but the touch screen is very inaccurate until the 10 mins has passed and it works fine again.

I spoke to my local LR dealer about it and they said it is likely to be a capacitor issue where it is being charged during starting the car and is slowly discharging itself to the point where after 10 mins it works fine. They said that by rubbing the screen I'm partly discharging it.

......as far as a replacement goes they said I should just put up with it as the cost of replacing the screen will be thousands of pounds Crying or Very sad

Has anyone ever heard of this problem?

The second problem is unfortunately going to be just as expensive to fix....

I noticed a strange intermittent hesitation (almost a shuddering of power) a couple of weeks ago when accelerating hard or when pulling up a hill. I took it to the dealer who initially told me it was because my tyres needed replacing (they were on their last legs) so I replaced them and it seemed fine for a couple of days until it started happening again. I took it in again and they called me a couple of hours later to suggest I sat down before they told me the bad news......

They said the shuddering under power was caused by play in the road wheels. They said I need to replace both the front lower control arms at a cost of 378 each! and then have the wheels aligned at a further cost of 120 - So that's 876 for starters..... they said if that doesn't cure it we need to look at the rear. In the rear they said there was a little play in the top rear hub bushes. Replacement would be 384 each. They said the rear track bar at a cost of 102 also needs replacing due to a bit of play.

All in all the suspension problem is likely to cost almost 2,000 and they haven't said that it's 100% the cause.

Any thoughts before I start parting with silly amounts of money?

Cheers
Grant

Post #358122 Thu Sep 27 2012 8:46pm
View user's profile Send private message View poster's gallery Post Reply
Post Reply  Back to top
Page 1 of 1
All times are GMT

Jump to  
Previous Topic | Next Topic >
Posting Rules
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



Site Copyright © 2005-2017 Futuranet Ltd & Martin Lewis
RRSPORT.CO.UK RSS Feed - All Forums

Switch to Mobile site