RRSPORT.CO.UK

    Forum   Gallery   Shop   Sponsors
Home > Technical > Limp home mode.
Post Reply  Down to end
Page 1 of 1
 
Andy B.



Member Since: 04 Oct 2017
Location: Suffolk
Posts: 7

United Kingdom 2010 Range Rover Sport 3.0 TDV6 HSE Alaska White
Limp home mode.

MY10 RRS went into limp home mode recently. RAC called out and found oil on air filter and mass air flow sensors. Turbo making an unusual whooshing sound on rev reduction. Turbos removed and sent away for examination. No problem with turbos on initial inspection other than oil being present. Fault code was regarding the mass air flow sensors. Any one have any ideas where the oil may be coming from and why there is an unusual noise sounding similar to a dump valve?

Post #548480 Tue Feb 13 2018 11:19am
View user's profile Send private message View poster's gallery Reply with quote
Andy K



Member Since: 18 Sep 2015
Location: GL
Posts: 1697

England 2005 Range Rover Sport TDV6 HSE Rimini Red

when the turbo VVT is jammed, you get the woosh noise when the revs drop.

You would have the engine light on though I would have thought

Post #548484 Tue Feb 13 2018 12:02pm
View user's profile Send private message View poster's gallery Reply with quote
Andy B.



Member Since: 04 Oct 2017
Location: Suffolk
Posts: 7

United Kingdom 2010 Range Rover Sport 3.0 TDV6 HSE Alaska White
Limp home mode.

Thanks Andy. Turbos been returned tomorrow. Would really like to know where this oil is coming from?

Post #548485 Tue Feb 13 2018 12:21pm
View user's profile Send private message View poster's gallery Reply with quote
Disco_Mikey
Site Sponsor


Member Since: 08 Apr 2012
Location: Dundee, Scotland
Posts: 2970

United Kingdom 

TCOV seized. Known issue. Nice, cheap repair

Assuming the MAF's are not actually at fault. Which begs the question, why are the turbo's off? Confused MMP Land Rover - Land Rover + Range Rover Specialist
www.Facebook.com/MMPLandRover

Unit 9, 42 Baird Avenue
Dundee
DD2 3TN

Alive Tuning Authorised Dealer - Performance Tuning + EGR Deletes

Servicing + Repairs / Fault Diagnostics / EU3+EU4 EGR Blanking / Brakes Serviced/Replaced / Timing Belt + Oil Pump Replacement

Software Updates+Upgrades:
4x4 Info Enable / Sat Nav OTM / 3 Flash indicators / RRS Timed Climate Retrofit

Post #548486 Tue Feb 13 2018 12:22pm
View user's profile Send private message View poster's gallery Reply with quote
Andy B.



Member Since: 04 Oct 2017
Location: Suffolk
Posts: 7

United Kingdom 2010 Range Rover Sport 3.0 TDV6 HSE Alaska White
Limp home mode.

Thanks Disco Mikey.RAC called out. Read fault codes, checked air filter and air mass flow sensors. Oil everywhere. Diagnosed faulty turbo. Vehicle under 2 year warranty so turbos taken off and sent to specialist for examination authorised by warranty company. Will pass on info to indie and hope to have everything re installed by the weekend. Any other ideas where the oil originated?

Post #548499 Tue Feb 13 2018 1:45pm
View user's profile Send private message View poster's gallery Post Reply
Post Reply  Back to top
Page 1 of 1
All times are GMT

Jump to  
Previous Topic | Next Topic >
Posting Rules
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



Site Copyright © 2005-2018 Futuranet Ltd & Martin Lewis
RRSPORT.CO.UK RSS Feed - All Forums

Switch to Mobile site